Supported technologies

Java

FrameworkVersion
JavaJava 7, 8,11, and 18
App/Webservers
  • Glassfish 5.1.0
  • Payara 4.1.1
  • Jetty 9.4.28.v2020040
  • Tomcat 8
  • WSO2-EI 6.1.1 + ESB
  • JBoss 7.3+
  • Wildfly 20.0
  • Weblogic 12.2+
Play2.5 (Play limitations)
Operating SystemLinux

Play limitations

  • spans are not getting linked for play
  • error will be captured only if java error handler is used
  • error wont get captured with scala error handler

.Net

FrameworkVersion
.Net Framework2.0, 3.0, 3.5, 4.0,4.5, 4.5.2, 4.6, 4.7.x, 4.8.x
.Net core2.x, 3.x
.Net5, 6, and 7
Node14

GO

FrameworkVersion
Framework
  • Gin Framework 1.5.0
  • Mux/Gorilla Framework
DatabaseMYSQL 5 & 8

PHP

FrameworkVersion
PHP7.2
FrameworkLaravel Framework 5.7
App/WebserversPHP FPM app server 7.2 (7 and above)
DatabaseMYSQL 5 & 8
Operating SystemUbuntu and CentOS 7

NodeJs

FrameworkVersion
Express Framework4.17.1
DatabaseMYSQL 5 & 8

Python

FrameworkVersion
Python3.6
Framework
  • Flask
  • Django
  • Pyramid
Operating SystemLinux